Errors: OLEDB

You may receive one of the following errors when connecting to Excel or Access:
  • System.Data.OleDb.OleDbException: The Microsoft Office Access database engine cannot read the data in ... The minimum required version to read the data is 14.0.0000.0000.
  • System.Data.OleDb.OleDbException: The Microsoft Office Access database engine cannot read the data in ... The minimum required version to read the data is 16.0.0000.0000.
  • System.InvalidOperationException: The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine.
  • System.InvalidOperationException: The 'Microsoft.ACE.OLEDB.15.0' provider is not registered on the local machine.
  • System.InvalidOperationException: The 'Microsoft.ACE.OLEDB.16.0' provider is not registered on the local machine.

Sync & Save uses the Microsoft OLEDB database driver to read from Excel (xlsx) and Access (mdb and accdb) files as well as to write to Access (mdb and accdb) files.

Installing Access automatically installs the OLEDB database driver.

If Access is not installed, there are several different versions of the OLEDB driver that can be installed:
If you receive the "minimum required version" error, please follow these steps to resolve the issue:
  1. Download and install install an OLEDB driver that is equal to or greater than the version mentioned in the error.
  2. Configure Sync & Save to use the correct version of OLEDB by opening Tools | Options | Jobs | General, and adjusting the OLEDB Version setting.
If you receive the "provider is not registered" error, please follow these steps to resolve the issue:
  1. Make sure the bit version of Sync & Save and Access match. If you have a 32 bit version of Office installed (most common), even if you have a 64 bit version of Windows, you must use the 32 bit version of Sync & Save.
  2. Download and install the OLEDB driver mentioned in the error.
  3. Configure Sync & Save to use the correct version of OLEDB by opening Tools | Options | Jobs | General, and adjusting the OLEDB Version setting.
By default Sync & Save uses OLEDB version 12.0. The option to select the specific version of OLEDB is available beginning with version 1.13.40.

Feedback and Knowledge Base